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Introduction

System Requirements

Greetings and a warm welcome!

Now you have the chance to unleash your productivity power. And we hope that our 

product will help you to do so.

So, it is time to meet our first creation. It is small, but its abilities are extensive. It is 

powerful, but not almighty. Now you are the master and in your hands its power will be 

invincible.

And... and we are glad that you've choosen our product. 

Thank you.

Operating System :   Microsoft Windows 2000 or Windows XP (this product was not 

   tested  to compatibility with Win9x series. If you have these 

                                  versions we cannot guarantee proper program functioning.)

Host Application:       Adobe After Effects 5.0 or higher

CPU:                           AMD or Intel processor

RAM:                         128Mb (system requirements) or higher

Hard Disk  Space:        less than 3Mb 

                                  (incl. documentation and samples)

*

* There's no Macintosh version of plug-in at this time

fx
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Customer Support

This manual provides all the information you need to get the most out of VVfx Bump 

Mapper™. It will help you learn the application and serve as a reference as you attempt 

more sophisticated procedures and effects.

This user guide assumes you are already familiar with basic Windows concepts-menus, 

dialogs, and mouse operations, such as clicking and dragging. If you need more 

information on these subjects or the Windows Desktop, refer to the Microsoft® 

Windows® User's Guide, respectively.

It also assumes that you are already comfortable with the basic concepts, features and 

terms of Adobe® After Effects®.

If you're not familiar with terms like layer, footage and render, you should spend some 

time with the Adobe® After Effects® documentation before using this guide.

The best way to learn VVfx Bump Mapper™ is to read  on page 4 and 

then complete the  on page 11. The tutorial leads you through the process of 

creating illustrations and animations in VVfx Bump Mapper™ and also explains

some of the important concepts you'll need to know about.

After you complete the tutorial, open new  file and start building your own footage.

"Getting Started"

"Tutorials"

Technical Support is  to registered users of VVfx Bump Mapper™. There are two 

easy options to contact technical support for questions about installation, configuration 

or functionality. These options are: Web and e-mail support. For questions about 

creative technique, please see the Creative Support section below.

You will find the answers to most of your questions within the pages of this User Guide. 

If you need further assistance, you may contact VVfx's Technical Support in any of the 

following ways:

Many of the answers to your questions are available 24 hours a day on our website:

http://support.vivid-fx.com

In addition to frequently asked questions, our web site provides troubleshooting 

techniques, late breaking product news, and other resources to get the most out of 

Bump Mapper.

To answer your technical support question most effectively and quickly, please use the 

e-mail form provided to you on our website:

http://support.vivid-fx.com

If you do not have World Wide Web access, please send e-mail to:

support@vivid-fx.com

There is no Phone Support at this time.

If you have questions regarding creative technique, please refer to our message boards 

on our website:

http://forum.vivid-fx.com

This area is available only for registered users to meet and talk with other users of Bump 

Mapper to share knowledge, technique, and inspiration.

free*

Web Support

E-mail Support

Phone Support

Creative Support

* Vivid Visual Effects does not currently charge for technical support for Bump Mapper. 

The only expense to the user is the Internet access charges which are solely 

responsibility of the program user.

Note:

2

Vivid Visual Effects reserves the right to change its support policies at 

any time.

http://vivid-fx.com/support.htm
http://vivid-fx.com/support.htm
mailto:support@vivid-fx.com?subj=Problem
http://vivid-fx.com/forum.htm
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Who is Vivid Visual Effects

For more Information

Vivid Visual Effects (VVfx) was founded in 2001. We are innovative company on the 

market of graphic software, developing and marketing new generation of products that 

improve your creativity and effectiveness of your products.

Our company develops plug-in effects for image and video editing software.

VVfx products are engineered to deliver real-time interaction and intuitive functionality 

for graphics professionals, graphics amateurs and consumers who work on personal 

computers.

Vivid Visual FX offers our clients smart, powerful and flexible tools for compositing and 

video editing.

We hope, that our technologies will help you in your work. People, who trust us find 

more than just plug-ins. We make your work more simple and fun!

For more information about VVfx' products, see our World Wide Web site on the 

Internet:

http://vivid-fx.com

fx
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Overview

Using Multiple Effects

The Effect Controls Window

Using Bump Mapper

This chapter provides the basic information you'll need to get started using Bump 

Mapper.

This chapter covers the general procedure for applying effect. It also includes 

instructions for using the interface tools. It also includes suggestions that will help you 

get the most out of the effects.

To use full power of Bump Mapper you need to combine it with multiple effects 

applied to a layer. All effects will be listed in the Effect Controls window. When you 

make the movie, After Effects renders the effects in the order they are listed in the 

controls window. Each subsequent effect uses the result of the previous effect as its 

starting point. Often, the ultimate result depends on which effect renders first. To get 

the results you want, you'll need to arrange the effects in an appropriate order.

The Effect Controls window lists the applied effects and provides the controls for 

changing them. What these controls mean is covered in the effects chapters and later in 

this guide.

If you close a layer's Effect Controls window, you can reopen it.

1. Select the layer in the Time Layout window.

2. Choose Layer menu -> Open Effect Controls.

1. In the Effect Controls window, select the effect you want to remove. Click the name to 

select it.

2. Press "Delete" button. You may also choose Edit menu -> Clear.

1. Select the layer.

2. Choose Effect menu -> Remove All.

To Open the Effect Controls window:

To Remove an effect:

To Remove all effects from a layer:

You'll apply Bump Mapper to layers in an Adobe After Effects composition. It works in a 

single layer.

You can apply Bump Mapper to any type of layer-standard footage item, nested 

composition, or pre-composed layer.

To apply an effect:

 Open the project where you want to work. The composition needs at least one layer, 

where you'll apply the effect. You can create a solid color layer by choosing Layer-> New 

Solid (or press Ctrl+Y).

 In the Time Layout window, select the layer where you want to apply the effect.

You can click on the name of the layer or on its duration bar.

 From the Effects menu, choose the category (-=Vivid Visual Effects=-) and select 

Bump Mapper effect from the sub-menu. When you've selected an effect, After Effects 

applies it to that layer and opens the Effect Controls Window (ECW). When you apply an 

effect, or change its parameters, After Effects updates the preview in the Composition 

window. This may take a moment.

1.

2.

3.

fx
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What is Bump Mapper

Section 1: LIGHT PROPERTIES

Bump Mapper™ Effect can turn your image or video layer into bas-relief alighted by 

point light source. Varying plug-in parameters let you obtain incredible visual effects.  

Glass or metal, plastic or stone, water or sand - you can simulate different textures and 

effects using Bump Mapper™ controls. You can use it to make a bronze coin or liquid 

gel or something unprecedented before. You can start with simple picture.

LIGHT POSITION

SPOTLIGHT RADIUS

AMBIENT COLOR*

By using this control you can set the 

position of a spotlight. Default position 

is a center of a layer. 

By using this control you can set the 

Radius of a spotlight. 

Default Radius is 400.

Minimal Radius is 1. If you set minimal 

Radius you receive just ambiently 

colored layer (fully dark )

Maximal Radius is 10 000.

By using this control you can set the 

Ambient component of a spotlight. 

Ambient Color is one of three 

c o m p o n e n t s  w h i c h  f o r m  a n  

illumination of a layer. It gives a 

colorification of a layer. If you use Black 

as Ambient Color you receive rounded 

light that shine through dark; using 

White as Ambient Color, you receive 

simply white-colored layer.

Ambient Default color is Black.

fx
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On the image (left) you see Bump 

Mapper's Controls Window. It 

contains various controls. We 

examine all of them separately. You 

will receive practical advices in the 

next Chapter.

Controls are separated into two 

major sections.

The first section has a name "LIGHT 

PROPERTIES". It contains controls 

that change parameters of a light 

source, e.g. position, radius and color 

components of light and illumination 

inversion control.

The second section is "SURFACE 

PROPERTIES". In this section you can 

change  a surface type, surface 

smoothing, relief height, height 

variation, surface equalization  and 

invert surface.

Bump Mapper Controls Window
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DIFFUSE COLOR*

SPECULAR COLOR*

INVERT ILLUMINATION

By using this control you can set the 

Diffuse component of a spotlight. 

Diffuse Color is one of three 

c o m p o n e n t s  w h i c h  f o r m  a n  

illumination of a layer. It gives a 

colorification of a relief and is what 

makes the object look red or green or 

whatever color you choose. If you use 

Black as Diffuse Color you receive 

monochromatic spotlit relief and if you 

use White as Diffuse Color you receive 

hard shadows.

Ambient Default color is Orange.

By using this control you can set the 

Specular component of a spotlight. 

Specular Color is one of three 

c o m p o n e n t s  w h i c h  f o r m  a n  

illumination of a layer. It gives a 

colorification of a highlights and is 

what makes the object look like metal 

or plastic. If you use Black as Specular 

Color you receive  plastic-like layer and 

if you use White as Diffuse Color you 

receive white reflections from relief.

Ambient Default color is White.

This check box swaps places of 

Ambient and Specular Light and you 

receive "negative"-like image.

fx
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* These three components of light is heart of effect. Just combine theirs and you receive 

absolutely different surface types. They are dependent among themselves
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Section 2: SURFACE PROPERTIES

SURFACE TYPE

SURFACE SMOOTHING

RELIEF HEIGHT

RELIEF HEIGHT VARIATION

RELIEF HEIGHT EQUALIZATION

INVERT SURFACE

By using this control you can set type 

of a surface. Higher values make your 

layer look more "plastic". Lower values 

make you layer more "metallic".

Default value is 10.

Minimal value is 1.

Maximal value is 50000.

By using this control you can smooth a 

relief, but you lose small details.

Minimal value is 0. Default value is 0.

Maximal value is 255 (slow calculating)

By using this control you can increase 

or decrease a height of relief.

Minimal value is 0. If you set "0" value 

you receive just flat layer spotlit by 

spotlight.

Maximal value is 100.

Note: Using higher values you can 

make very different visual effects but 

they will be not like relief surface.

Only values from 1 to 5 form realistic 

relief (higher values are useful for 

bigger layers).

By using this control you can increase 

or decrease a reflections of light and 

reflected light from relief.

Minimal value is -254. No light you can 

see using this value.

Maximal value is 255. You receive very 

high brightness and your relief will be 

flat white layer.

It is very useful and necessary control. 

Equalization does little details more 

visible. But will be careful! If you use 

lossy compressed images (e.g. JPG) 

you can see the art ifacts of 

compression on your relief.

Minimal value is 1 (No Equalization).

Maximal value is 10000.

Note: High levels of Equalization can 

make your image looks like "oil-

painted" picture, because they 

decrease palette (non-smooth fills), 

which forms rendered surface.

This control changes the state of relief. 

Points that were prominent will be 

bulged-in

fx
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BLEND WITH ORIGINAL

Standard control that mix original and 

filtered layers. Use it to receive special 

results like "embossed picture"
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Tutorial 1: Red "Rocky" Words

This chapter provides information about advanced techniques and directions for use of 

Bump Mapper.

This chapter covers more useful techniques and plug-in combinations for great results. 

It also includes sample images of composed effects.

Overview

12

On the image at the left you 

see the result of work of 

Bump Mapper with joint use 

of standard After Effects 

plugins. They are:

1. Basic Text (from "Text" 

Category)

2. Gaussian Blur (from "Blur 

& Sharpen" Category)

3. Fractal Noise (from 

"Render" Category).

We learn how to make these 

"rocky" words.

 Create a solid color layer by choosing Layer -> New Solid (or press Ctrl+Y).

 From the Effects menu, choose the category "Text" and select "Basic Text" effect 

from the sub-menu. When you've selected an effect, After Effects applies it to that layer 

and opens the Effect Controls Window (ECW).

In dialog window type your text (we type "BUMP 

MAPPER"). Press OK.

In Composition Window you 

must see red-colored words.

 To receive more 

volumetric letters we need to 

use "Gaussian Blur" effect 

from "Blur & Sharpen" 

Category.Select "Horizontal 

& Vertical" Blur Dimensions. 

Do not blur too much!

 This step is grand! For 

what we need to add some 

noise? It needs because 

Bump Mapper effect use the 

image as map of attitudes! If 

you'll use a color-filled layer 

you'll receive only flat surface alighted by point light source.

Select "Fractal Noise" from "Render" Category of Effects. After noise addition we'll 

receive great map of attitudes. Choosing different types of noise we receive different 

types of surfaces! Just experiment with. 

 And the last step. Select "Bump Mapper" effect from "-=Vivid Visual Effects=-" 

Category. Learn about Bump Mapper controls in on in chapter II "Effect Controls 

Description". We use Red Color (R:RED_MAX, G:0, B:0) as Diffuse Color. Try to adjust 

"Relief Height Equalization" to receive more realistic surface! 

That's ALL!

To download this tutorial as After Effects pre-made project visit our website's Download 

section

Please, send us a sample of your project and we will display it in our Gallery section on 

our website .

Step 1.

Step 2.

Step 3.

Step 4.

Step 5.

page 9 

Proud of your work?

http://vivid-fx.com

Result of Bump Mapper's processing 

The steps of "Rocky Words" creation 

http://vivid-fx.com/gallery.htm


On the image at the left you see the 

result of work of VVfx Bump Mapper 

with joint use of standard After Effects 

p lugin -  "Drop Shadow" from 

"Perspective" Category.

We learn how to make these "old" 

bronze coin on green cloth.

 We use as coin attitudes map the 

scan of quarter dollar's coin. After scan 

we adjust the levels of scanned image 

and cut the coin from a background. 

You can use Adobe® Photoshop® to 

make these operations or use After 

Effects® Masks and "Brightness & 

Contrast" effect from "Adjust" Category 

of standard effects.

 Import Coin image into After Effects by selecting File -> Import -> File...(or press 

Ctrl+I) and place at the Timeline in center of Composition Window. 

 We need to have "green cloth" so we 

insert green Solid layer under the coin. Create 

a solid color layer by choosing Layer -> New 

Solid (or press Ctrl+Y).

 Now we 

can add our 

legend on the 

coin! Just use 

" B a s i c  T e x t "  

effect for Coin 

layer from the 

" T e x t "  s u b -

menu. Select 

"Composite on 

O r i g i n a l "  

checkbox and 

select Black as the text Color. Add "Bump 

Mapper" effect from "-=Vivid Visual Effects=-" 

sub-menu. Use Orange as Diffuse Color. The 

rest controls are shown on the image at the 

left.

 Add "Drop Shadow" effect from the 

"Perspective" sub-menu. 

To download this tutorial as After 

Effects pre-made project visit our 

website's Download section

Please, send us a sample of your 

project and we will display it in our 

Gallery section on our website 

.

Step 1.

Step 2.

Step 3.

Step 4.

Step 5.

Proud of your work?

http://vivid-fx.com

Tutorial 2: "Old" Bronze Coin
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Processed 
Image

Scanned 
Coin

Processed 
Image

Frame rendered using Bump Mapper

Effect Controls Window

Before and After Bump Mapper Processing

http://vivid-fx.com/gallery.htm
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THIS LICENSE AGREEMENT IS A LEGAL AGREEMENT BETWEEN YOU, THE END USER, AND VIVID 

VISUAL EFFECTS COMPANY. IT IS A LICENSE AGREEMENT AND NOT AN AGREEMENT FOR SALE. 

PLEASE READ THIS LICENSE AGREEMENT CAREFULLY . IF YOU DO NOT AGREE WITH THE TERMS 

AND CONDITIONS OF THIS LICENSE AGREEMENT, PROMPTLY DELETE THIS SOFTWARE, BUNDLED 

DOCUMENTATION AND SAMPLES FROM YOUR HARD DRIVE. 

 

This software can only be used on a single computer at any one time. This means that the software 

should be loaded on only one hard drive at a time. If you wish to use this software on more than one 

computer, you must either erase the software from the first hard drive when you move the software 

to a second hard drive, or else purchase two copies of the software. You may not under any 

circumstances have this program loaded onto the hard drives of two or more computers at the same 

time. You also may not copy this software onto a hard drive and then use the disks on another 

computer. The software may be executed from a common disk shared by multiple computers 

provided that one authorized copy of the software has been licensed for each computer executing 

the software. 

This software is owned by Vivid Visual Effects and is protected by United States copyright laws and 

international treaty. By law, you, the end user, may do the following: 

a) make a copy of the software solely for backup or archival purposes; 

or 

b) transfer the software to a single hard disk, provided you keep the original solely for backup or 

archival purposes. 

United States copyright laws prohibits you from making any other copy of the software for any 

reason without our permission. These federal copyright laws also prohibit you from copying the 

written materials accompanying the software without first obtaining our permission. 

You may not rent, lend, lease, or assign this software. You may, however, transfer the software and 

the accompanying written materials on a permanent basis. When you transfer the software on a 

permanent basis, you may not keep any copies, and you must remove the software from your hard 

disk. Also, the person to whom you transfer the software must agree to the terms of this License. 

You may not alter, modify or adapt the software or accompanying materials. In addition, you may 

not translate, decompile, disassemble or reverse engineer the software. You also may not create any 

derivative works based on this software. A derivative work is defined as a translation or other form in 

which the software may be recast, transformed or adapted. 

 

Vivid Visual Effects Company warrants that this program will perform in substantial compliance with 

the published specifications and documentation supplied in this package, provided it is used on the 

computer hardware and with the operating system for which it was designed. This warranty is 

limited to a period of 90 days from the date of the original purchase.  

 

If you report a significant defect in performance of the software in writing, within 90 days of 

purchase, Vivid Visual Effects Company will attempt to correct it or, at its option, authorize a refund 

of your license fee. 

Except as specifically provided above, Vivid Visual Effects Company makes no other warranty or 

representation, either express or implied, with respect to this software or documentation, including 

their quality, merchantability, or fitness for a particular purpose. In no event will MetaCreations 

Corporation be liable for direct, indirect, special, incidental, or consequential damages arising out of 

the use or inability to use the software or documentation, even if Vivid Visual Effects Company has 

been advised of the possibility of such damages. 

The warranties and remedies set forth above are exclusive and in lieu of all others, oral or written, 

express or implied. 

Vivid Visual Effects Company is not responsible for any costs including, but not limited to, those 

incurred as a result of lost profits or revenue, loss of time or use of the software, loss of data, the 

costs of recovering such software or data, the cost of substitute software, claims by third parties, of 

other similar costs. In no case will Vivid Visual Effects Company's liability exceed the amount of the 

license fee. 

The warranties provided give you specific legal rights. You may have other rights which vary from 

state to state. Some states do not allow the exclusion of incidental or consequential damages, or the 

limitation of how long an implied warranty lasts, so some of the above may not apply to you. 

Vivid Visual Effects Company Bump Mapper™ and documentation thereto are provided with 

RESTRICTED RIGHTS. Use, duplication or disclosure by the Government is subject to restrictions as 

set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at 

52.227-7013. The contractor/manufacturer of Bump Mapper and documentation thereto is Vivid 

Visual Effects Company.

VIVID VISUAL EFFECTS  Software License

1. License 

2. Copyright 

3. Restrictions 

4. Limited Warranty

5. Remedies

6. No Other Warranties 

7. U.S. Government Restricted Rights 
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